Back to overview
Degraded

Degraded performance

Dec 04 at 09:51am GMT
Affected services
Application

Resolved
Dec 04 at 11:48am GMT

We are pleased to announce that the solution has been successfully implemented, resolving the previous performance issues. The website is now operating at optimal levels and we appreciate your understanding during this time.

Created
Dec 04 at 09:51am GMT

We are experiencing technical difficulties with our driver portal, resulting in prolonged loading times between page loads. Our team has identified the root cause and is working to implement a solution. We apologise for any inconvenience this may cause during the interim period.