Back to overview
Downtime

Degraded performance

Feb 24 at 03:01pm GMT
Affected services
Application
Application
Application

Resolved
Feb 24 at 04:02pm GMT

The issues causing downtime and degraded performance are now fully resolved. We apologise for any inconvenience this caused.

Updated
Feb 24 at 03:51pm GMT

The systems should now start returning to a more stable state. However, we are still expecting some users to experience intermittent issues until we have fully resolved the problem.

Created
Feb 24 at 03:01pm GMT

We are aware of an ongoing issue with our systems which is causing degraded performance and downtime for some users. The cause of the issue is known and we're currently working on resolving the problem as soon as possible.