Back to overview
Degraded
Issues making payments with Apple Pay
Apr 16 at 11:31am BST
Affected services
Application
Resolved
Apr 16 at 02:52pm BST
We are pleased to inform that all technical issues with Apple Pay have been rectified, resulting in seamless payment transactions. We apologise for any inconvenience this may have caused and appreciate your patience during this time.
Affected services
Application
Created
Apr 16 at 11:31am BST
We are experiencing difficulties with users successfully completing Apple Pay transactions due to an issue with our payment processing partner, which is currently being addressed. We will provide updates as more information becomes available.
Affected services
Application